OpenOffice für Menschen mit Behinderungenzugänglich machen

OpenOffice ist eine interessante Alternative zu Microsoft Office. Viele Kritikpunkte an OOo haben weder Hand noch Fuß. Es mag sein, dass es einige Funktionen aus MSO in OOo nicht gibt, aber die wenigen Hardcore-Nutzer, die mehr als 5 Prozent der Funktionalität eines durchschnittlichen Office-Pakets verwenden, sollen auch den dreistelligen Betrag für Microsoft Office ausgeben.

Das hier beschriebene gilt analog auch für LibreOffice. Eine gute auf OOo basierende Alternative ist IBM Lotus Symphony. Sie läuft wesentlich flotter als OOo und wird von den Entwicklern von NVDA empfohlen.

Dass Word-Dokumente sich nicht ohne Weiteres öffnen und speichern lassen ist eher Microsoft anzulasten. Dass Microsofts Office-Paket oft genug Probleme hat, ältere Dokumente der eigenen Produktreihe zu öffnen, hat inzwischen auch jeder mitbekommen.

OpenOffice ist in der Standardkonfiguration für Screenreader nicht zugänglich. Die Zugänglichkeitsoptionen müssen aktiviert werden und das erfordert an einigen Stellen Hilfe von Sehenden.

Zunächst einmal muss die Java Access Bridge installiert werden. Außerdem muss eine Java-Laufzeitumgebung installiert sein.

Dann startet man OOo und wählt unter Extras -> Optionen den Bereich Zugänglichkeit. Hier klickt man das erste Feld “Unterstützung behindertengerechter Zugangsprogramme” an.

Gegebenenfalls muss noch unter Optionen unter Java “Eine Java-Laufzeitumgebung verwenden” aktiviert werden, was aber in der Standardkonfiguration schon aktiviert sein dürfte.

Ich habe die Zugänglichkeit von OOo für Blinde und Sehbehinderte nur oberflächlich und natürlich mit vollkommen veralteter Software getesttet. Deshalb will ich generell keine Aussagen zur Zugänglichkeit der einzelnen Anwendungen machen. Ich werde es mal intensiver ausprobieren und einen Bericht zur Bedienbarkeit abgeben.
Nach meinen Tests denke ich, dass OpenOffice insbesondere durch die Java-Laufzeitumgebung so stark ausgebremst wird, dass es praktisch unbenutzbar ist. Das gilt für die aktuellen Versionen 3.x. Es hängt weniger mit dem hohen Bedarf an Arbeitsspeicher zusammen. Ohne Java braucht OpenOffice recht lang für den Start, läuft dann aber recht gut. Mit Laufzeitumgebung können einige Aktionen mehrere Minuten dauern, so viel Geduld bringt wohl kein Nutzer wirklich auf. Daher rate ich zur Nutzung des Ablegers IBM Lotus Symphony, dass die Accessibility-Schnittstellen anders implementiert hat und daher nicht von der Java Access Bridge abhängig ist. Auch Symphony ist speicherhungrig, sollte aber auf halbwegs aktuellen Computern gut laufen.

Weiterführendes

Zugängliches PDF mit OpenOffice

2 Gedanken zu „OpenOffice für Menschen mit Behinderungenzugänglich machen“

  1. Pingback: Barrierefreie PDFs mit IBM Lotus Symphony | Blind-Text
  2. Hallo,

    LibreOffice ist seit Version 3.6 auch barrierefrei. Allerdings habe ich folgendes Problem:

    ich habe mich riesig gefreut als ich bei der Installation von LibreOffice 3.6 gelesen habe, dass an Menschen mit Behinderung gedacht wurde! Seit dem Jahr 2000 kämpfe ich dafür dass die Standardsoftware barrierefrei wird und 12 Jahre später ist libre die erste Software die es umsetzt! Einfach klasse!

    Meine Freude wurde etwas getrübt, als ich es ausprobieren wollte!
    Man geht in den Menüpunkt “Extras”, dann in die “Optionen”.
    Dann klickt man bei der Rubrik “LibreOffice” auf den Punkt “Zugänglichkeit”. “Zugänglichkeit” bedeutet “Barrierefeiheit”.

    Wenn ich nun die “Unterstützung behindertengerechter Zugangsprogramme” aktiviere und danach auf den OK-Schalter klicke, bekomme ich folgende Fehlermeldung:

    “LibreOffice benötigt eine Java-Laufzeitumgebung (JRE), um diese Aufgabe durchführen zu können. Die ausgewählte JRE ist defekt. Bitte wählen Sie eine andere Version aus oder installieren Sie eine neue JRE und aktivieren Sie diese unter Extras – Optionen… – LibreOffice – Java.”

    Ich habe unter XP(VMWare) die jre nochmal frisch installiert – hat nichts geholfen, gleiche Fehlermeldung.

    Habe die aktuelle JRE und danach LibreOffice 3.6 unter Windows 7 installiert – ebenfalls die gleiche Fehlermeldung!

    Haben Sie eine Idee?

    Über eine Rückmeldung würde ich mich sehr freuen!

    Herzliche Grüße

    Markus Lemcke

Kommentare sind geschlossen.